Web tasarım

your php installation appears to be missing the mysql extension which is required by wordpress hata çözümü

Bu içeriğimizde çok sık karşılaşılan Wordpress, your php installation appears to be missing the mysql extension which is required by wordpress. hatasının çözümünü anlatacağız.

Hata sebebi

Hata kodundan yer alan uyarı; php kurulumunuz, wordpress için gerekli olan mysql uzantısını eksik görünüyor hatasıdır.

Bu, sunucunuzdaki PHP kurulumunun Wordpress’i MySQL veritabanınıza bağlamak için gerekli Mysql uzantısına sahip olmadığı anlamına gelir. Bu uzantı desteği PHP 7.0 ve üst versiyonlarda kullanımdan kaldırılmıştır.

Bu hata mesajını görüyorsanız, Wordpress sitenizin kodunun kullandığınız PHP sürümüyle uyumlu olmadığı anlamına gelir.

Bu sorun en çok yeni WordPress kurulumlarında, özellikle de Linux gibi varsayılan olarak Mysql uzantısını içermeyen belirli işletim sistemlerinde yaygındır. Bir siteyi taşırken veya sunucu yapılandırmanızı değiştirirken de ortaya çıkabilir.

your php installation appears to be missing the mysql extension which is required by wordpress hata çözümü

PHP kurulumunuzda WordPress için gerekli olan Mysql uzantısı eksik görünüyor için bir kaç çözüm yöntemi vardır.

İlk Çözüm

Bu hata mesajını düzeltmenin ilk ve en basit çözümü, wordpress’i en son sürüme yükseltmektir. Bunu yapmak için kontrol panelinize giriş yapın ve aşağıdaki resimdeki gibi güncellemeleri seçin :

bir sonraki ekranda wordpress sürüm güncellemeleri bölümünün altındaki Şimdi Güncelleye tıklayarak sürümünüz güncelleyin. Güncelleme tamamlandığında sorun düzelmiş olacaktır.

İkinci Çözüm

Birinci yöntem ile hata düzlemedi ise bu yöntemle, Mysql uzantısının kurulu ve etkin olup olmadığını doğrulamaktır . Bazı işletim sistemleri, varsayılan olarak Mysql uzantısını içermez. Bunlardan birini kullanıyorsanız, kendiniz yüklemeniz gerekecek.

İlk olarak, ftp aracılığıyla wordpress sitenizin ana kök dizinine info.php dosyası oluşturarak yükleyin. yükleme bittikten sonra alanadınız.com/info.php urlsini açın. PHP kurulumunuzun ayrıntılarını içeren bir sayfa göreceksiniz.

mysql bölümünü arayın uzantı kuruluysa, İstemci API’sinin yanında sürümü göreceksiniz.

Cilent API libarary versiyon boş ise uzantı yüklenmemiştir. Yükleme adımları sistemlere göre değişiklik gösterir. Cpanel de Wordpress PHP sürümü güncelleme içeriğimizi inceleyerek bunu kolayca yapabilirsiniz.

Hosting yönetiminde Cpanel giriş yaparak Select PHP version kısmına girerek 7.0 ve üst versiyonları seçerek değişiklikleri kaydedin; ardından hatanın çözülüp çözülmediğini görmek için sitenizi yenileyin.

Sonuç olarak bu anlatımlar doğrultusunda işlemleri eksiksiz yaparsanız aldığınız hata düzelmiş olacaktır. Yorum kısmında sorunlarınız bize iletmekten çekinmeyin.

İlgili İçerikler

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Başa dön tuşu